Click here to check old Google mail server

Compatibility Guide

The following is a list of software that will work with our service. This list is not the only software that is compatible with us, we work with much more, however this is the most common software.

Operating Systems

  • Windows 95 / 98 / ME / CE / 2000 / NT / XP
  • Mac OS X
  • Mac OS 8.X and up
  • Windows 3.1 *
  • Linux *
  • WebTV *
  • Palm OS *

* The software works with powrup.net, however technical support does not provide setup support. You must know how to setup your machine. High speed is supported on Windows 95b, 98, ME, 2000, NT, & XP only.

Browsers

  • Internet Explorer
  • Netscape
  • Mozilla
  • Opera
  • Mozilla Firebird
  • Safari (Mac Only)

Email Clients

  • Outlook Express
  • Outlook (all versions)
  • Eudora (all versions)
  • Netscape Mail
  • Incredimail
  • Pegasus
  • Entourage

Instant Messengers

  • AOL IM
  • MSN Messenger
  • ICQ
  • Yahoo Messenger
  • Trillian

 

Copyright 2004 Powrup.net All Rights Reserved